Koltec gsi astra problem owners help needed pls

Post Reply
Message
Author
mrwrigit
New member
Posts: 3
Joined: Thu Aug 11, 2016 9:19 am

Koltec gsi astra problem owners help needed pls

#1 Post by mrwrigit » Fri Aug 12, 2016 11:05 pm

hiya, i have purchased and rebuilt engine on my astra g with the koltec gsi lpg system on, I have a 1.6 z16se 2001 with the lpg on and have 2 empty plugs and need to know where they go, I cant see anything for them to go into, one is 8 pin and 1 is 10 pin but the gas system will not switch with code 12 and 22 now engine rotation and low tps signal and I think its because something is missing out of these plugs. if any1 has 1 or knows the system to take a picture or explain what goes into it or to trace the missing wiring so I can make it up that would be great. If I activate the relay I've got gas right up to the injectors I would be very gratefull. I cannot find a schematic on the net that matches the system to make th wiring up myself. This is the plugs
Image
Many thanks if any1 can help

Brian_H
Intermediate Member
Posts: 1073
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: Koltec gsi astra problem owners help needed pls

#2 Post by Brian_H » Sun Aug 14, 2016 8:30 pm

Can't suggest a lot, but code 12 you can ignore. There should be a cut through on the engine loom for TPS - both this and the rpm signal tap should trace to somewhere in the loom, so start with finding the connection to each and tracing where it actually goes.

Theres a good chance that the plugs are just from the loom themselves - It might be useful to check what the wire colours in the back of those plugs are if you can't find any other info - PJPJ had a load of info on the site linked in his signature, but I can't get it to load at present properly - its worth a look here if its working again (theres some schematics there from what i remember, the EGI ones aren't particually helpful, the GSI ones slightly better).

http://homepage.ntlworld.com/paul.joyce ... ystem.html

Based on what i can see from the pictures I'd suspect one of those is the injector cut circuit as well (there isn't that many wires in the system to start with - 18 would sound like most of them to me) - Have you swapped the engine complete with the loom, or removed your engine and done repairs to it?

mrwrigit
New member
Posts: 3
Joined: Thu Aug 11, 2016 9:19 am

Re: Koltec gsi astra problem owners help needed pls

#3 Post by mrwrigit » Sun Aug 14, 2016 10:22 pm

Hiya Brian_h thanks for your reply. I get the code 12 even with engine running that's why I suspect an rpm or cam signal. I've been trying to get that page to load for over a week now, I fear it's gone. I've just rebuilt the head and put a new set of rings on so only disconnected the nessesary and all gone back in same place. I bought the car needing the work done but don't know if the engines been changed or not.

Brian_H
Intermediate Member
Posts: 1073
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: Koltec gsi astra problem owners help needed pls

#4 Post by Brian_H » Sun Aug 14, 2016 11:53 pm

Code 12 is normal ignore it. The other one is going to be your problem. I've got that page saved I'll try and dig it out for you tomorrow.

kbs
Junior Member
Posts: 225
Joined: Wed Jul 03, 2013 12:38 pm

Re: Koltec gsi astra problem owners help needed pls

#5 Post by kbs » Mon Aug 15, 2016 8:33 pm

I dont think these are 'cut into the loom'.
Was this LPG from new?
Is it logging a fault in petrol OBD?

Brian_H
Intermediate Member
Posts: 1073
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: Koltec gsi astra problem owners help needed pls

#6 Post by Brian_H » Mon Aug 15, 2016 10:24 pm

Brian_H wrote:Code 12 is normal ignore it. The other one is going to be your problem. I've got that page saved I'll try and dig it out for you tomorrow.
Found the file i was looking for with the codes in - its 2b4f58d84237d173_gsifailurecodes from that link i've sent to you via pm.

Code 12 is a start of codes signal - not an error code (you may be looking at the EGI codes rather than GSI)

Code 22 is your relevent one - the tps signal. The EGI system intercepts this so I'd have a look at the connections there and see if anythings amiss there first.

Has it ever worked on lpg in the time you've had it?

mrwrigit
New member
Posts: 3
Joined: Thu Aug 11, 2016 9:19 am

Re: Koltec gsi astra problem owners help needed pls

#7 Post by mrwrigit » Wed Aug 17, 2016 10:29 pm

thanks for the info and the links, I'm gonna have a look through and see if theres anything that can help me, the gas has never worked, well say never I only got it 2 month ago and was just parked up for 5 weeks while I did the rings and the head but previous owner reakoned they used to use it before it was stood a while but you never know.

Post Reply