Hi, what have I got here then?

Post Reply
Message
Author
jamesfuller
New member
Posts: 7
Joined: Fri May 30, 2014 5:56 pm

Hi, what have I got here then?

#1 Post by jamesfuller » Fri May 30, 2014 7:42 pm

Hi, I'm a classic car enthusiast, particularly into Mercedes. I have just been to pick up my latest purchase and it is fitted with a gas system, it wont run on it though!

The car runs fine on petrol but when you change over to gas the engine just dies. The lights say it has some gas and this is confirmed by the gauge in the boot. (approx half a tank)

I have no idea what the system is, the certificate says OMVL single hole and its an 80 litre tank.

If it has a filter I would like to check it and replace if needed, other than that I think I will take it to an LPG place for a check over!

Could any one advise on the going price for diagnostics, filters and servicing?
Also any recommendations in the Bedford area for a company that could deal with what I assume is a basic old (2002) system?

Thanks in advance.

Talkingcars
Junior Member
Posts: 201
Joined: Sun Oct 23, 2011 5:52 pm
Location: West Sussex
Contact:

Re: Hi, what have I got here then?

#2 Post by Talkingcars » Fri May 30, 2014 8:07 pm

Welcome aboard.

Do you know who fitted the system?

Alternatively can you give us names from the gas ECU and or the evaporator that will be in or very close to the engine, photos would also help.

Another clue is the style of switch on the dash.

James

Gilbertd
Advanced Member
Posts: 7982
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: Hi, what have I got here then?

#3 Post by Gilbertd » Fri May 30, 2014 8:15 pm

OMVL and 2002 says it will be a single point with a gas mixer bolted to the air intake. It might have a Millenium lambda controller or it might be a simple open loop system. Have a look at the hose running between the vaporiser (a big aluminium thing with hoses going to it that will be under the bonnet somewhere) and the mixer (probably bolted to the throttle body). Somewhere along it's length it will have either a manual valve (so it's open loop) or a stepper motor controlled electrical valve (closed loop lambda controlled system).

Most likely cause of it switching over and dying is that the gauge is lying and you've no gas in it or one of the solenoids has stuck (or not getting any power) so the gas isn't getting through.
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.

jamesfuller
New member
Posts: 7
Joined: Fri May 30, 2014 5:56 pm

Re: Hi, what have I got here then?

#4 Post by jamesfuller » Fri May 30, 2014 10:32 pm

Thanks for the replies, I will have a dig around in the engine bay tomorrow and update here.

After going through the cars history, there is an invoice from Economy fuel systems Ltd of Stourbridge, same company as on the certificate, but it doesn't go into detail. The price was £850 + vat

jamesfuller
New member
Posts: 7
Joined: Fri May 30, 2014 5:56 pm

Re: Hi, what have I got here then?

#5 Post by jamesfuller » Sat May 31, 2014 8:37 pm

Got some photos of the system...
Image
Image
Image
Image

jamesfuller
New member
Posts: 7
Joined: Fri May 30, 2014 5:56 pm

Re: Hi, what have I got here then?

#6 Post by jamesfuller » Sat May 31, 2014 8:42 pm

How would I go about checking the solenoids?
If I put a multimeter on the live wire, when would I expect it to switch, as the gas is switched over? or is it not that simple?

Also, do you have to fill up the LPG tank or can I put say £10 in just to try it?

Gilbertd
Advanced Member
Posts: 7982
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: Hi, what have I got here then?

#7 Post by Gilbertd » Sat May 31, 2014 8:52 pm

What you have is an Emmegas lambda controlled single point system. The gauge on the tank appears to be showing that it is empty so a bit of gas would be a good idea. As long as you get some in, even a fivers worth would be enough. That would work out to about a gallon and a half, plenty enough to test it but not so much that it'll take a week to vent it all out in case you have to.

It will have been set to changeover to gas when conditions are right. That would mean it will need to be seeing pulses from the ignition system to tell it the engine is running and that the revs are correct. Usually it will be set to change over on deceleration at a certain revs, maybe 1,500, maybe 2,000 rpm. So it will start on petrol and then change over when you blip the throttle. At that point you will see 12v appear on the solenoids, one on the tank and another on the vaporiser. If you test resistance to earth on the live side of one of the solenoids, you should see a resistance of around 8 Ohms as each solenoid coil should have a resistance of about 15 ohms each.
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.

jamesfuller
New member
Posts: 7
Joined: Fri May 30, 2014 5:56 pm

Re: Hi, what have I got here then?

#8 Post by jamesfuller » Sat May 31, 2014 9:05 pm

Thanks Gilbertd.

As the Multimeter is buried in the depths of the garage, I shall go put a little gas in and see what happens.

Much appreciated, thanks again.

jamesfuller
New member
Posts: 7
Joined: Fri May 30, 2014 5:56 pm

Re: Hi, what have I got here then?

#9 Post by jamesfuller » Sun Jun 01, 2014 11:48 pm

I put in some gas and no joy. I haven't gone any further with it yet as the car wouldn't start this morning. How would this system shut off the petrol, does it switch the fuel pump power feed? And is this done by a control unit or from the switch?

Gilbertd
Advanced Member
Posts: 7982
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: Hi, what have I got here then?

#10 Post by Gilbertd » Mon Jun 02, 2014 12:18 am

It's all done by the control unit, not the switch. It will either disconnect the common power feed to the petrol injectors with a relay or by using emulators which places resistors in place of the injectors to the petrol ECU doesn't get offended. Fuel pump feed isn't normally touched and the fuel pump will run even when running on gas.
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.

jamesfuller
New member
Posts: 7
Joined: Fri May 30, 2014 5:56 pm

Re: Hi, what have I got here then?

#11 Post by jamesfuller » Mon Jun 02, 2014 12:31 am

Ok, thats great thanks.

Post Reply