Page 1 of 1

Hi, what have I got here then?

Posted: Fri May 30, 2014 7:42 pm
by jamesfuller
Hi, I'm a classic car enthusiast, particularly into Mercedes. I have just been to pick up my latest purchase and it is fitted with a gas system, it wont run on it though!

The car runs fine on petrol but when you change over to gas the engine just dies. The lights say it has some gas and this is confirmed by the gauge in the boot. (approx half a tank)

I have no idea what the system is, the certificate says OMVL single hole and its an 80 litre tank.

If it has a filter I would like to check it and replace if needed, other than that I think I will take it to an LPG place for a check over!

Could any one advise on the going price for diagnostics, filters and servicing?
Also any recommendations in the Bedford area for a company that could deal with what I assume is a basic old (2002) system?

Thanks in advance.

Re: Hi, what have I got here then?

Posted: Fri May 30, 2014 8:07 pm
by Talkingcars
Welcome aboard.

Do you know who fitted the system?

Alternatively can you give us names from the gas ECU and or the evaporator that will be in or very close to the engine, photos would also help.

Another clue is the style of switch on the dash.

James

Re: Hi, what have I got here then?

Posted: Fri May 30, 2014 8:15 pm
by Gilbertd
OMVL and 2002 says it will be a single point with a gas mixer bolted to the air intake. It might have a Millenium lambda controller or it might be a simple open loop system. Have a look at the hose running between the vaporiser (a big aluminium thing with hoses going to it that will be under the bonnet somewhere) and the mixer (probably bolted to the throttle body). Somewhere along it's length it will have either a manual valve (so it's open loop) or a stepper motor controlled electrical valve (closed loop lambda controlled system).

Most likely cause of it switching over and dying is that the gauge is lying and you've no gas in it or one of the solenoids has stuck (or not getting any power) so the gas isn't getting through.

Re: Hi, what have I got here then?

Posted: Fri May 30, 2014 10:32 pm
by jamesfuller
Thanks for the replies, I will have a dig around in the engine bay tomorrow and update here.

After going through the cars history, there is an invoice from Economy fuel systems Ltd of Stourbridge, same company as on the certificate, but it doesn't go into detail. The price was £850 + vat

Re: Hi, what have I got here then?

Posted: Sat May 31, 2014 8:37 pm
by jamesfuller
Got some photos of the system...
Image
Image
Image
Image

Re: Hi, what have I got here then?

Posted: Sat May 31, 2014 8:42 pm
by jamesfuller
How would I go about checking the solenoids?
If I put a multimeter on the live wire, when would I expect it to switch, as the gas is switched over? or is it not that simple?

Also, do you have to fill up the LPG tank or can I put say £10 in just to try it?

Re: Hi, what have I got here then?

Posted: Sat May 31, 2014 8:52 pm
by Gilbertd
What you have is an Emmegas lambda controlled single point system. The gauge on the tank appears to be showing that it is empty so a bit of gas would be a good idea. As long as you get some in, even a fivers worth would be enough. That would work out to about a gallon and a half, plenty enough to test it but not so much that it'll take a week to vent it all out in case you have to.

It will have been set to changeover to gas when conditions are right. That would mean it will need to be seeing pulses from the ignition system to tell it the engine is running and that the revs are correct. Usually it will be set to change over on deceleration at a certain revs, maybe 1,500, maybe 2,000 rpm. So it will start on petrol and then change over when you blip the throttle. At that point you will see 12v appear on the solenoids, one on the tank and another on the vaporiser. If you test resistance to earth on the live side of one of the solenoids, you should see a resistance of around 8 Ohms as each solenoid coil should have a resistance of about 15 ohms each.

Re: Hi, what have I got here then?

Posted: Sat May 31, 2014 9:05 pm
by jamesfuller
Thanks Gilbertd.

As the Multimeter is buried in the depths of the garage, I shall go put a little gas in and see what happens.

Much appreciated, thanks again.

Re: Hi, what have I got here then?

Posted: Sun Jun 01, 2014 11:48 pm
by jamesfuller
I put in some gas and no joy. I haven't gone any further with it yet as the car wouldn't start this morning. How would this system shut off the petrol, does it switch the fuel pump power feed? And is this done by a control unit or from the switch?

Re: Hi, what have I got here then?

Posted: Mon Jun 02, 2014 12:18 am
by Gilbertd
It's all done by the control unit, not the switch. It will either disconnect the common power feed to the petrol injectors with a relay or by using emulators which places resistors in place of the injectors to the petrol ECU doesn't get offended. Fuel pump feed isn't normally touched and the fuel pump will run even when running on gas.

Re: Hi, what have I got here then?

Posted: Mon Jun 02, 2014 12:31 am
by jamesfuller
Ok, thats great thanks.