Landi Renzo Omegas on P38 Rover V8

Post Reply
Message
Author
SteveFarmer
New member
Posts: 2
Joined: Sun Mar 16, 2014 12:50 am

Landi Renzo Omegas on P38 Rover V8

#1 Post by SteveFarmer » Sat Jun 28, 2014 1:25 am

HI

I have a 99 Range Rover P38 with Omega sequential injection and I have a couple of questions about the sotfware

1) I notice in vehicle config that it seems to think there is only one lambda sensor, when in fact there are two, should I change this setting?

2) The changeover to LPG is set to 1600 rpm which is relatively high for this motor, I once drove for quite a distance without switchover because it sits around 1200 rpm @ 60 KPH. Is it sensible and safe to drop this to say 1200 RPM?

3) The only doc I can find on using the auto-tune says to hold the engine at 3000RPM while the software does it's thing. Is this the correct RPM for an engine like this?

And finally if I do make these changes (1 & 2), I assume I need to write them back to the ECU

Thanks
Steve

Gilbertd
Advanced Member
Posts: 7984
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: Landi Renzo Omegas on P38 Rover V8

#2 Post by Gilbertd » Sat Jun 28, 2014 7:43 am

Assuming the Landi system is a piggy back unit the same as most other multipoints, it doesn't use the lambda sensors, just displays them on the screen as an aid to fault finding. Changing it to 2 will probably give you a display of both (assuming they are both connected).

The P38 I've got with an egas system on it is also set quite high so I have to give it some revs to force it to change over. My main one on a single point is set for 1200 and I intend changing it on the egas too once I get it running on all 8!

Can't help you with 3 though but I would have thought 2,500 would be high enough for a low revving P38 motor.

Don't know enough about the Landi software to say if it will automatically save any changes or not, so can't help on that.
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.

SteveFarmer
New member
Posts: 2
Joined: Sun Mar 16, 2014 12:50 am

Re: Landi Renzo Omegas on P38 Rover V8

#3 Post by SteveFarmer » Sun Jun 29, 2014 12:17 am

Hi

Thanks for that, the software kept dying when I tried to use the auto tune feature so I didn't get to do any tuning.

Since I serviced it and replaced faulty injectors it is now running much better than it ever has

Off to the professionals for a tuneup next I think!

Regards
Steve

Brian_H
Intermediate Member
Posts: 1080
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: Landi Renzo Omegas on P38 Rover V8

#4 Post by Brian_H » Thu Aug 07, 2014 9:48 pm

The save and load (f6/7) functions on the front screen save or load the config to/from a file. Changes in the calibration are applied at the completion of the calibration. I'm fairly sure from memory that the changes to the first screen are instant as there isn't any way to actually apply it. Easy way to test the rpm setting is change it, exit from the software and check if its changed either by reconnecting again or seeing when it changes. Mine shows 800 rpm as minimum you can set it to.

Don't know on the other bits.

dodgeboy
New member
Posts: 9
Joined: Sun Aug 03, 2014 7:12 pm

Re: Landi Renzo Omegas on P38 Rover V8

#5 Post by dodgeboy » Sat Aug 16, 2014 7:43 pm

those settings that are on yours are the same for my v8 in my dodge ram. im sure mine changes at under 1600rpm tho.

Post Reply