Page 1 of 1

range rover p38 4.6

Posted: Sun Feb 24, 2013 7:33 pm
by matcossy
hi guys,

i hope some one can shed some light on an issuse i have with my lpg,
its a romano system, the thing is some times it will switch back to petrol with the gauge bleeping has any one got any idea?? what is cursing this??

regards matt

Re: range rover p38 4.6

Posted: Sun Feb 24, 2013 7:45 pm
by Tubbs
You have to hook it up to a laptop and have a look. It could be low LPG pressure, temp related or an actual logged fault. Without looking its hard to say. Have you checked your coolant level ?

Re: range rover p38 4.6

Posted: Sun Feb 24, 2013 7:48 pm
by classicswede
Pressure loss.

You just need to work out why you are loosing pressure. Under what conditions does it switch back?

Re: range rover p38 4.6

Posted: Sun Feb 24, 2013 9:04 pm
by matcossy
hi,,

some times its when im coasting some times under full throttle,
it does do it more when im at half a tank or below,,

how do i plug it in to my lap top??

best regards matt

Re: range rover p38 4.6

Posted: Sun Feb 24, 2013 9:43 pm
by Tubbs
You need an interface lead and the software. If you get in touch with mint lpg they will have the software. The lead is a standard aeb. But you need the number off the back of the romano ecu for the sofware. Prefix b,c,d etc.
ebay autogas interface lead aeb...

Re: range rover p38 4.6

Posted: Sun Feb 24, 2013 9:56 pm
by matcossy
hi,

iv just been on ebay and found that i can get software and lead of there is it simple to use??

best regards matt

Re: range rover p38 4.6

Posted: Sun Feb 24, 2013 10:12 pm
by classicswede
Nothing that complex. Just load it up, plug the lead in and then take some screen shots. Post up the screen shots and we should be able to confirm if things look right.

Re: range rover p38 4.6

Posted: Tue Feb 11, 2014 9:32 pm
by matcossy
hi iv plug the laptop into the ecu and my gas pressure is 1.24 bar is this ok

regards

Re: range rover p38 4.6

Posted: Tue Feb 11, 2014 10:24 pm
by Gilbertd
You need to see what the gas pressure is when running under different conditions. Ideally at the time it switches back. Get someone to watch the display while you drive, it might be pressure, it might be temperature, it might be something else, just look for something that changes.

Re: range rover p38 4.6

Posted: Fri Mar 14, 2014 9:51 pm
by matcossy
ok chaps iv sorted it :D

it got to the point where it was constantly switching back to petrol so I plug the lap top in and it was not seeing any pressure at all so I felt around the pressure sensor and as soon as I touched it I got pressure back so I started the car got it going on gas and the poke the sensor again and again it went back to petrol so iv found that by cable tieing the wires forward and that seems to have fixed it,,,

the sensor is a aeb013 does anyone no where I can get one from???

regards matt

Re: range rover p38 4.6

Posted: Fri Mar 14, 2014 10:13 pm
by Gilbertd
The AEB013 was notoriously unreliable and has been superseded by the AEB025. You'll need an adapter cable to fit the 025 to your existing loom. You'll find both the sensor and adapter cable about 2/3rds the way down this page http://www.tinleytech.co.uk/acatalog/AEB.html