Search found 1280 matches

by Brian_H
Mon Jun 17, 2019 7:13 pm
Forum: Having Problems ?
Topic: Gas won’t switch from LPG to Petrol
Replies: 23
Views: 123

Re: Gas won’t switch from LPG to Petrol

Guessing that will be in fuse box sorry for confusion but it does start petrol within couple off seconds switch to gas Won't be in fuse box, the wires leading to the petrol injectors would have been fed into the lpg ECU loom somewhere. Most likely somewhere near the plugs that connect to the petrol...
by Brian_H
Wed Jun 12, 2019 10:10 pm
Forum: Having Problems ?
Topic: Gas won’t switch from LPG to Petrol
Replies: 23
Views: 123

Re: Gas won’t switch from LPG to Petrol

Its possible there is something wrong with your injector wiring (to the existing petrol injector loom from the lpg loom). Can you confirm what ECU/system it is, and how you have got the wiring connected (which colours on the lpg loom to which colours on the cars own loom)
by Brian_H
Wed Jun 05, 2019 11:23 pm
Forum: General Discussion
Topic: Zetecs on gas and multiple tanks
Replies: 6
Views: 68

Re: Zetecs on gas and multiple tanks

I've had approx 50k on gas (engine now somewhere past 200k - hard to say exactly how far as the speedo drops out and stops recording intermittently, I've been waiting for the clutch to wear out to deal with it as the sensor causing that doesn't want to move) with JLM flash lube used on it. Its still...
by Brian_H
Wed Jun 05, 2019 10:36 pm
Forum: General Discussion
Topic: Zetecs on gas and multiple tanks
Replies: 6
Views: 68

Re: Zetecs on gas and multiple tanks

The "factory fit" heads used on the ones converted by Tickford have the hardened seats - Mine came off at 242k as it had slight vsr developing, but was able to be rectified without new seats (which are apparently £50 a valve to do if they need replacements cutting in when I enquired about it). Thoug...
by Brian_H
Tue Jun 04, 2019 7:44 pm
Forum: Having Problems ?
Topic: warning
Replies: 3
Views: 64

Re: warning

Could be, could also be an injector error being detected as that would cause the above, likely fix for that may be as simple as unplug the injectors and reseat the connectors again, which did cure it for me. A bad connection to the battery terminals might also be the cause. Best bet would be to have...
by Brian_H
Wed May 29, 2019 6:10 pm
Forum: General Discussion
Topic: Omegas Black Injectors
Replies: 3
Views: 62

Re: Omegas Black Injectors

Any idea what model/Firmware version the ecu you have got is using? Theres a few versions of Omegas and some of them are a bit newer than others. Also what vehicle its fitted on will help to answer - A guess says its something with 6 cylinders from your question, but probabbly need a bit more info t...
by Brian_H
Mon May 27, 2019 10:47 am
Forum: Having Problems ?
Topic: Low gas pressure but still switching sometimes
Replies: 4
Views: 86

Re: Low gas pressure but still switching sometimes

The gauge on the tank should show the level of gas in the tank. Won't stop it switching over, it's just used to drive the lights on the gauge. Does sound like a sticky or weak solenoid to me though.
by Brian_H
Sun May 26, 2019 11:31 pm
Forum: Having Problems ?
Topic: Low gas pressure but still switching sometimes
Replies: 4
Views: 86

Re: Low gas pressure but still switching sometimes

Most likely you have a little flow from the tank to front end, but not enough. Typically that would be down to a problem with the solenoid, either gummed up or defective coil both possible causes. Wiring maybe possible, but easier to rule out other causes first. First thing if you want to check if i...
by Brian_H
Sun May 26, 2019 4:49 pm
Forum: General Discussion
Topic: Omegas Black Injectors
Replies: 3
Views: 62

Re: Omegas Black Injectors

Only place I've seen selling them recently is Tinley Tech

https://tinleytech.co.uk/shop/lpg-parts ... ueblack-2/

TBH you'd be better replacing the injectors with newer better ones if your ecu supports anything, those ones aren't particularly great, and are expensive as well.
by Brian_H
Tue May 21, 2019 11:12 pm
Forum: Having Problems ?
Topic: reducer temp. sensor spec
Replies: 9
Views: 147

Re: reducer temp. sensor spec

Probably more important to get one matched to the ECU your using? Does it screw into the reducer directly or is it on a coolant line? Which ECU us it your using?
by Brian_H
Sat May 18, 2019 7:42 pm
Forum: General Discussion
Topic: lpg feed pipe size on 500 bhp engine.
Replies: 304
Views: 35399

Re: lpg feed pipe size on 500 bhp engine.

Easiest option to get between 12mm and 16mm is to buy a filter with the outlets you want to convert between. Just be glad your not dealing with anything using the 14mm size that Landi used for some reason, even finding the pipe to fit that properly was a pain.
by Brian_H
Tue May 14, 2019 4:07 pm
Forum: General Discussion
Topic: lpg feed pipe size on 500 bhp engine.
Replies: 304
Views: 35399

Re: lpg feed pipe size on 500 bhp engine.

That listing actually has 2 sets not just one so might be a bit cheaper than your thinking. Those are the same injectors all my current vehicles use and i've got no complaints about them, With nozzles removed they can cope with a Rover v8 4.0 Thor if that helps?
by Brian_H
Tue May 14, 2019 4:04 pm
Forum: Having Problems ?
Topic: Slight gas smell - normal?
Replies: 5
Views: 76

Re: Slight gas smell - normal?

That being the case, I'd suspect your leak is somewhere on the feed itself - if its more at the front than elsewhere, the solenoid post on the vapouriser would be worth checking (you might not see that with the spray either as the point of leaking would be obscured). I'd expect if it was there, that...
by Brian_H
Mon May 13, 2019 9:02 pm
Forum: Having Problems ?
Topic: Slight gas smell - normal?
Replies: 5
Views: 76

Re: Slight gas smell - normal?

Possibly as you won't get even fueling if one is leaking. Its worth going round the jubilee clips to check they are tight as well. If you have the software then monitor gas pressure when it's on petrol or engine not running, it should stay reasonably static
by Brian_H
Mon May 13, 2019 5:53 pm
Forum: Having Problems ?
Topic: Slight gas smell - normal?
Replies: 5
Views: 76

Re: Slight gas smell - normal?

Not usually no, if you can smell it then it sounds like you have a leak. Only 2 places it's likely to develop a leak and not be detected by the spray is the vacuum connection from the vapouriser to inlet manifold, or the injectors not closing properly. If you can access the hoses then remove an end ...
by Brian_H
Thu May 02, 2019 5:02 pm
Forum: Having Problems ?
Topic: Ford Transit Mk7 Landirenzo/Omegas problem
Replies: 42
Views: 818

Re: Ford Transit Mk7 Landirenzo/Omegas problem

I'd suggest before you make that trip. check why the EML is on - Reason being is if its on for some reason outside of the lpg side of things, you might want to address it before you make a trip anywhere to fix the lpg side. You already have Forscan (which I've got and find very capable, will let you...
by Brian_H
Wed May 01, 2019 10:45 pm
Forum: Having Problems ?
Topic: Ford Transit Mk7 Landirenzo/Omegas problem
Replies: 42
Views: 818

Re: Ford Transit Mk7 Landirenzo/Omegas problem

The lpg software will only show codes generated by the lpg system, most of which will stop it running on gas.

Does forscan tell you why the eml is coming on?
by Brian_H
Wed May 01, 2019 8:57 pm
Forum: General Discussion
Topic: Toyota 2AZ-FE on gas
Replies: 5
Views: 121

Re: Toyota 2AZ-FE on gas

You do need to avoid it running too lean - which would be done via the setup and calibration. You also need to setup the dose rate, but again this would be done at that point (not a bad idea to check it when you refill though) Trouble is that table only tells you a little of the info you'd need to d...
by Brian_H
Wed May 01, 2019 8:00 pm
Forum: General Discussion
Topic: Toyota 2AZ-FE on gas
Replies: 5
Views: 121

Re: Toyota 2AZ-FE on gas

Its a lot cheaper to put the lube system on and fill it than to have to have the cylinder head repaired so probably a good idea unless someone can confirm its not needed (fairly sure most Japanese engines are recommend to have flashlube/valve saver fitted)
by Brian_H
Wed May 01, 2019 7:52 pm
Forum: General Discussion
Topic: Toyota 2AZ-FE on gas
Replies: 5
Views: 121

Re: Toyota 2AZ-FE on gas

Don't know about your particular engine, but the valve saver stuff does work - I've got a Ford Zetec that has done 50k on gas, with jlm valve saver fluid used on it and its still working now. The Zetec is known for having soft valve seats which don't stand up well on gas without lube, Mines still go...