LPG Forum


All times are UTC



Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Greetings
PostPosted: Tue Mar 03, 2009 1:09 pm 
Hi All

I have an ex RAF 110 V8 (without restrictors) Soft top.

We had the LPG system fitted some 4 years a go. Its a Landi system into twin SUs with 2x 45 ltr tanks in the 'side-lockers' found on some military 110s

She has a few little querks :
1. Starting on LPG....no chance unless its 10 degrees c or above. I have frozen the thing a few times :roll: . I don't use LPG below freezing unless its a motorway run :?
2. Stalling: if you brake hard when on LPG she will stall. havent decides whether its petrol using momentum to push thru the system or gas surge for the same reason. Will also cut out at low revs if the engine is getting a bit hot such as slow traffic.
3. IF she has been on gas for a while and I go back to petrol she will suffer from over rich mixture. I did think the gas was still on but she has done it when I've run out of LPG completely. Give her 10 mins and she'll be OK on petrol


Top
  
Reply with quote  
 Post subject:
PostPosted: Wed Mar 04, 2009 7:45 am 
1. I badly described this bit - I'm talking cold start in the morning etc. It does pick up heat from just by the heater matrix

2.the regulator thing sits to the side of the engine bay, and no, no posey air intakes for me :wink:


Will what replacement vapouriser would you recommend for a 3.5 v8?


Top
  
Reply with quote  
 Post subject: Re: Greetings
PostPosted: Thu Mar 05, 2009 8:09 pm 
Intermediate Member

Joined: Sat Aug 23, 2008 5:39 pm
Posts: 1129
Location: Cumbria
dennis61 wrote:
I have an ex RAF 110 V8 (without restrictors) Soft top.

We had the LPG system fitted some 4 years a go. Its a Landi system into twin SUs with 2x 45 ltr tanks in the 'side-lockers' found on some military 110s

She has a few little querks :
1. Starting on LPG....no chance unless its 10 degrees c or above. I have frozen the thing a few times :roll: . I don't use LPG below freezing unless its a motorway run :?

I assume here you mean it starts, but then freezes and dies ? Or does it not start at all ?
What you describe is classic symptoms of poor flow through the reducer. The heater matrix on a 110 has b***er all resistance to water flow so there will be next to no pressure to push water round the reducer. It would be interesting to stick a hose clamp on one of the heater hoses and force the water through the reducer - bet it improves.
Quote:
2. Stalling: if you brake hard when on LPG she will stall. havent decides whether its petrol using momentum to push thru the system or gas surge for the same reason. Will also cut out at low revs if the engine is getting a bit hot such as slow traffic.

And after it cuts out, is it by any chance a right pain to restart - as though it's "flooded" ? If the water flow is so low as to barely keep the reducer above "frozen solid", then it's possible that there is liquid gas in the reducer where there should normally only be vapour. Reduce the gas take off rate (which reduces the heat input required) and increase the heat input, and you could get a significant increase in gas supply.
Quote:
3. IF she has been on gas for a while and I go back to petrol she will suffer from over rich mixture. I did think the gas was still on but she has done it when I've run out of LPG completely. Give her 10 mins and she'll be OK on petrol

Could still be the same - liquid gas remaining in the reducer.

For the reasons given, I don't tee into heater hoses on a Land Rover - I always plumb the reducer in series with the heater. On my Discovery I simply took the hoses off where the metal pipe runs underneath the manifold (this si the return pipe), and took a hose from the heater matrix to the reducer, and then another hose to the back of the water pump (or you could leave the short hose on the pump and take the hose from the reducer to the metal pipe where it emerges behind the manifold.

I have an article on just this subject :roll:

PS - as Rossko already hinted - your antifreeze needs to be at full strength.

PPS - does it use any water ? How are your head gaskets ? If a head gasket is even so much as starting to think of going, then the air creates airlocks in the heater circuit - and as explained, there isn't the pressure to clear the reducer.

_________________
Land Rover 110 V8 LPG
Land Rover 90 petrol (no longer diseasel :D), still awaiting V8 & LPG
http://www.diy-lpg.co.uk


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Fri Mar 06, 2009 10:26 am 
Well the Reducer is in parallel ...could try replumbing it

I'm not losing any water, and the antifreeze is 25%+ .

If its very cold she just won't start. She might run for a few seconds if its not really cold but then die....and thats it. Put on Petrol and wait 10 mins

In the stall, She is a pain to restart, about 15 seconds :(

If I'm doing a lot of stop start I pull the choke out 5mm to up teh revs to 1000ish - not fuel efficient but less embarrasing . Had a major stall just outside bracknell on a roundabout at 17.30 hrs - I've never been so abused by fellow motorists :shock:

I'm going to try replumbing to series and up the antifreeze to 35%. I have a pipe with a bleed valve built in from a Montego. If I put this in as the 'top' heater circuit hose then I could monitor any air.


Top
  
Reply with quote  
 Post subject:
PostPosted: Fri Mar 06, 2009 11:30 am 
Intermediate Member

Joined: Sat Aug 23, 2008 5:39 pm
Posts: 1129
Location: Cumbria
dennis61 wrote:
If its very cold she just won't start. She might run for a few seconds if its not really cold but then die....and thats it.

Hmm, something is wrong then, I've started my 110 (on carbs), and before that the Disco, for something like 8 or 9 years - and the only time either wouldn't start on gas was when the battery was low and there wasn't enough spark. Whatever cold weather we've had in the last 8 or 9 years (before I went EFI a year ago) - I've started on gas in it.
Quote:
In the stall, She is a pain to restart, about 15 seconds :(

If I'm doing a lot of stop start I pull the choke out 5mm to up teh revs to 1000ish - not fuel efficient but less embarrasing . Had a major stall just outside bracknell on a roundabout at 17.30 hrs - I've never been so abused by fellow motorists :shock:

That does sound like it's 'flooding' - does "switch off gas and petrol (ie no fuel supply), floor the throttle, crank it" have any effect ?
Quote:
I'm going to try replumbing to series and up the antifreeze to 35%. I have a pipe with a bleed valve built in from a Montego. If I put this in as the 'top' heater circuit hose then I could monitor any air.

The bleed valve isn't needed for monitoring - the system will self-purge air once the water is flowing. But the V8 + carb setup can be rather awkward to get the heater circuit purged in the first place. I find that if there is a lot of air (like when you had the system drained down for plumbing changes), then you start up, the pump pulls water round the look, the air reaches the pump, and the pump just stops working.

_________________
Land Rover 110 V8 LPG
Land Rover 90 petrol (no longer diseasel :D), still awaiting V8 & LPG
http://www.diy-lpg.co.uk


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Fri Mar 06, 2009 1:16 pm 
If i pop her into 'Both Off' as soon as I crank it defaults to Petrol (its an electronic 'soft touch button type)

I have,on occasions in the past, pulled the system fuse which disconnects both the Gas system and the electric fuel pump. Helps a bit but by the time I've messed about it was just as easy to sit & wait .

Looking at some other systems I think mine is a bit cheap and not a brilliant install under the bonnet- lots of rubber pipe everywhere. However the tanks set up & pumbing is neat.

Landi doesn't seem to get too may thumbs up :(

I have toyed with the idea of changing the reducer and the control switch

Having said that, in the summer its as good as gold :D


Top
  
Reply with quote  
 Post subject:
PostPosted: Sat Mar 07, 2009 6:29 pm 
Well, reducer now in series & anti-freeze boosted

Lets see what happens in the morning.......


Top
  
Reply with quote  
 Post subject:
PostPosted: Sun Mar 08, 2009 11:58 am 
Mmmm no change there :(

SHe does seem to 'dump a lot of gas when you turn they key.

What I need to do is reduce to 'choke' time

BUT ....i can't find the Landi idiots guide to reprogramming the timing

Any one got one for the 3 way push button switch by Landi?


Top
  
Reply with quote  
 Post subject:
PostPosted: Sun Mar 08, 2009 7:46 pm 
New member

Joined: Tue Nov 07, 2006 1:01 am
Posts: 47
To adjust the priming time; pop the switch out of the facia and you should find a plastic pot screw; turn anti clockwise to reduce the priming time.

Regarding your stalling problems; I would reccomend:

1, removing the screw at the bottom of the vapouriser to drain off the heavy oils.

2, find the 'minimo' screw on the vapouriser and, with the engine up to temperature, adjust to obtain the fastest engine speed. In the absence of a gas analyser this will be a 'near enough' setting, and should nail the stalling.

Also I agree with what others have said; cold starting on gas should be no problem.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Mar 08, 2009 9:33 pm 
I've sussed the 'electronic' choke timing......but it still like to dump gas for 2-3 seconds when cold irrespective of timings

What I really need is find a GOOD LPG installer/ set-er up-er...very rare in west wales

:(

I'll try some TLC


Top
  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group