LPG Forum


All times are UTC



Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Poor focus lpg starting.
PostPosted: Wed Jul 31, 2013 1:18 pm 
New member

Joined: Wed Jul 31, 2013 11:43 am
Posts: 1
I have a Ford Focus 2001 with a Tickford Metatron lpg system, The problem is starting from cold, When cold it cranks for some time, if I put the accelerator to the floor first it makes starting slightly easier, when it starts it is very rough running, as soon as it is running smoothly it then switches to gas and runs perfectly, it seems that if there is a hint of gas in the gas injector rail is where the problem is, If I release all the gas from the rail it will start immediately and run perfectly on petrol, This seems to be baffling everyone, Does anyone else have this problem.


Top
 Profile  
Reply with quote  
PostPosted: Wed Jul 31, 2013 3:00 pm 
Installer

Joined: Wed May 23, 2007 5:51 pm
Posts: 8096
Images: 0
Location: Wiltshire
Sounds like a dribbling injector. As its a high pressure liquid LPG system, that'll have a bigger effect than with gas injectors.

_________________
www.blazegas.com


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group