LPG Forum


All times are UTC



Post new topic Reply to topic  [ 18 posts ] 
Author Message
PostPosted: Sat Aug 29, 2015 8:33 am 
New member

Joined: Fri Aug 28, 2015 6:58 am
Posts: 8
Good morning all, an Essex newbie here in need of some help......

I have recently bought myself a Disco 2 that had been fitted with a BRC system just over 2 years ago. It was an expensive install (The receipt came in at £2700 :shock: )

On start up from cold, first thing in the morning, it starts fine but try and drive it and it all goes pear shaped. If you so much as dare attempt to touch the throttle it loses all power and virtually comes to a halt. You can get it up to around 30mph by going through the gears using just the tick-over and a very light amount of throttle. This continues for around 2 or 3 minutes until it finally switches over to gas when all then is well. It will occasionally throw a wobbler when pulling away but on the whole in normal driving its fine. Idle seems to be surging though rising and falling between around 400 and 700 rpm. Again, occasionally at a standstill it will just cut out but starts again with no problem.

I took it to a Landy V8 man in Leicester who suggested I try running it on petrol only for a week and to be fair it seemed to cure a lot of the problem. He reckoned that the ECU was reading a lean mixture when on gas and was basically adjusting the fuelling with petrol to attempt to cure it (obviously with no effect as its running LPG) meaning that on the first start of the morning its running super rich. He did plug it in and reported that all the sensors seemed fine.

The gas system was serviced about 8 months ago and on there it mentions that the fuel trims are out and a MAF was suspected. Not sure if that was ever changed but the MAF on there was an aftermarket cheapie so, knowing that some of these are rubbish I fitted a Bosch one yesterday.

Still running like a sick pig first thing this morning.

Any one have an idea where I could start to look?

Cheers

Adie


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 29, 2015 9:19 am 
Advanced Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 7897
Images: 0
Location: Peterborough
adie wrote:
He reckoned that the ECU was reading a lean mixture when on gas and was basically adjusting the fuelling with petrol to attempt to cure it (obviously with no effect as its running LPG) meaning that on the first start of the morning its running super rich.
Sounds like he's about spot on. The fuelling adjustments when on LPG DO have an effect on petrol. The LPG system piggybacks onto the petrol system rather than being completely separate. The amount of fuel going into the engine is adjusted by altering the length of time the injectors stay open for. On petrol this is calculated from the various sensors, MAF, TPS, temp, etc. The LPG system needs slightly longer opening times so it intercepts the pulses to the LPG injectors, adds a fiddle factor and fires the LPG injectors for what it has been told is correct. So if at a given revs and load the petrol injectors need to be open for 10mS and the LPG injectors need to be open for 14mS, the LPG system adds 4mS to the pulse. If this is programmed wrong, the petrol system sees that and alters the fuel trims to get it running at the correct mixture. Then when you come to run on petrol, the mixture is out. Running on petrol for a while will let the trims adjust themselves back to correct.

The Thor engine with Bosch fuel management as you have is very picky about the MAF. They do not respond to MAF cleaner and don't like aftermarket ones, you need to fit the genuine (gold plated from the cost) Bosch ones. If the MAF is reporting wrong airflow into the engine, the mixture will be wrong, it will be giving the amount of fuel that it thinks it needs rather than what it actually needs.

Now you have a genuine MAF sensor, run on petrol only for a couple of days and let the fuel trims settle to what they should be and it should run properly. Then try running on LPG and see if it stays that way or goes out again. If it goes out, the internal map in the LPG ECU (the fiddle factor) will need to be altered.

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 29, 2015 9:31 am 
New member

Joined: Fri Aug 28, 2015 6:58 am
Posts: 8
Thanks for the explanation.

I will give that a go then. Is it certain amount of miles needed to get the trims to settle?

If the ECU needs looking at does anyone know any good peeps around the Basildon area?

Cheers

Adie


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 29, 2015 9:51 am 
New member

Joined: Wed Mar 03, 2010 2:05 am
Posts: 62
Location: Grays, Essex, UK
I had this problem when I first got my DII as well.

As Gilbert said it is the LPG trims upsetting the petrol trims, which only get used with a cold engine until switch over to LPG.

Any OBD reader will show you the trims being used by the petrol EMS, from my (failable) memory the EMS will reset the trims after three journeys on petrol.

Then just track the change in trim when you switch onto LPG

It may be worth getting a lead and the software for your BRC system to see what settings you're currently running.

Joanne

_________________
Jemima Puddletruck - Land Rover Discovery 4.0 V8 with Zavoli multipoint LPG


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 29, 2015 9:57 am 
New member

Joined: Wed Mar 03, 2010 2:05 am
Posts: 62
Location: Grays, Essex, UK
It's probably also worth asking on the D2BC forum for a diagnostic check with a Hawkeye or Nanocom to make sure there aren't any underlying fault codes.

Joanne

_________________
Jemima Puddletruck - Land Rover Discovery 4.0 V8 with Zavoli multipoint LPG


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 29, 2015 10:34 am 
New member

Joined: Fri Aug 28, 2015 6:58 am
Posts: 8
Hi there

Thanks for the reply. The guy from Leicester checked out all the fault codes when I was there. MAF was a common fault code. Hopefully that will sort it!

On the D2BC site for my 'other' more worrying issues! Chassis and a small water leak! Good job I just bought a mahoosive tin tent to cart with it! lol

Cheers

Adie


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 29, 2015 10:36 am 
New member

Joined: Fri Aug 28, 2015 6:58 am
Posts: 8
Joanne3 wrote:
I had this problem when I first got my DII as well.

As Gilbert said it is the LPG trims upsetting the petrol trims, which only get used with a cold engine until switch over to LPG.

Any OBD reader will show you the trims being used by the petrol EMS, from my (failable) memory the EMS will reset the trims after three journeys on petrol.

Then just track the change in trim when you switch onto LPG

It may be worth getting a lead and the software for your BRC system to see what settings you're currently running.

Joanne


Is that software available? If so do you have a link?

Cheers

Adie


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 29, 2015 11:22 am 
New member

Joined: Wed Mar 03, 2010 2:05 am
Posts: 62
Location: Grays, Essex, UK
You'll need to identify exactly which BRC ecu you have, then try http://www.lpgshop.co.uk/lpg-diagnostic-software/ or Tinley Tech.

You'll also need an interface lead to connect your laptop to the ecu.

_________________
Jemima Puddletruck - Land Rover Discovery 4.0 V8 with Zavoli multipoint LPG


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 29, 2015 2:40 pm 
Advanced Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 7897
Images: 0
Location: Peterborough
If you have the BRC Seq24, Seq24my07 or the BRC Plug and Play, WTV (www.wtv-uk.co.uk) do interface cables (in both USB and RS232) that includes the software.

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
Reply with quote  
PostPosted: Sun Aug 30, 2015 10:59 am 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 3015
Location: Yorkshire
BRC software is probably the most complicated for novice users. On some BRC systems (those that don't have a manifold pressure sensor left fitted after calibration) it might be a bad idea for an amateur to attempt any adjustment.

BRC GB have been a lot more forthcoming with help for none BRC installers lately, they may sell you a proper BRC cable and let you have access to their software download site... Same cable works on all BRC systems except maybe Just (you don't have Just).

Another reason why the engine could run lean on LPG and rich on petrol - if the reducer diaghpram is leaking and the calibration was adjusted (with the leak present), say during the last service, the LPG map would now take into account the un-metered gas entering the inlet manifold from the reducer vac port but the petrol system wouldn't take into account the unmetered gas (so run too rich on petrol). This would effect running on petrol only when there is still pressure in the vapour side of the LPG system, so again the fault running on petrol would go away after a while... not as long as weeks or even days though, usually just minutes.

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
PostPosted: Tue Sep 01, 2015 6:30 am 
New member

Joined: Fri Aug 28, 2015 6:58 am
Posts: 8
Morning All

Thanks for the replies. As an update, run on petrol for a day or so doing multiple journeys. Switched to gas again Sunday evening for a few journeys then for the test first thing yesterday morning!

Started up, and all seems good. No hesitation, and a nice steady idle. Towed the caravan 80 odd miles and back again without a hiccup. Started again this morning and again, all seems fine. Thought it missed a bit right from the start but think I am now a little paranoid! So hopefully, all is now well!

Is there any local gas fitters to Basildon in Essex on here? I will need someone local to here or Chelmsford when its service is due?

Many thanks

Adie


Top
 Profile  
Reply with quote  
PostPosted: Fri Nov 13, 2015 11:48 am 
New member

Joined: Fri Aug 28, 2015 6:58 am
Posts: 8
Morning all

The disco has been running fine since my last post, but recently, when running on gas it seems to be missing when you push the throttle and load the engine.

As per my post above, are there any local to Basildon/Chelmsford LPG peeps on here who I can take it to for a once over?

Cheers

Adie


Top
 Profile  
Reply with quote  
PostPosted: Fri Nov 13, 2015 6:14 pm 
Advanced Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 7897
Images: 0
Location: Peterborough
When were your plugs and leads last changed? A misfire under load is usually a sigtn of a weak spark, plugs wear faster on LPG than on petrol and LPG needs a better spark in the first place. I run standard NGK plugs in mine and change them every 10,000 miles when I do an oil and filter change.

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 16, 2015 9:01 am 
New member

Joined: Fri Aug 28, 2015 6:58 am
Posts: 8
Had the plugs out a month or so ago. They looked pretty much like new.

Leads were changed a couple of years ago, but genuine not cheap and cheerfuls.

I was wondering if it could be a blocked filter? It feels so much like fuel starvation. On petrol, it pulls like a train which makes me think that somewhere along the line there is a restriction.

I know BRC sell a filter element that looks a bit like a K&N! I am assuming they are inside a canister, but is it something I can do or is it best left to someone who knows the LPG system? No mug with the spanners, but never played with gas before.

Cheers

Adie


Top
 Profile  
Reply with quote  
PostPosted: Tue Nov 17, 2015 10:41 pm 
Advanced Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 7897
Images: 0
Location: Peterborough
Filter change is dead easy although it is a good idea to release the gas pressure first or it will go with a bang that will scare the hell out of you. If you can get to the tank solenoid valve easily enough, you can run the car on gas and then disconnect the solenoid. That will use up the gas in the pipe from tank to the front solenoid/filter unit and the engine will die. If you can't you can slacken the inlet pipe to the filter and let the gas escape slowly. Other than that, it's just a simple swap.

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 18, 2015 10:42 am 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 3015
Location: Yorkshire
Agreed, and will just need decent circlip pliers to change the 'K&N style' element in a BRC serviceable filter... Or if the filter is the type without sensor (wires) or pressure take off (3rd smaller diameter pipe fitting) you could just replace it with a disposable type.

Unlikely a blocked filter is the problem though. Much more likely the plugs issue Gilbert described, especially if plug change coincided with recent misfire problems.

Just about to set off to a limo company to service a few BRC systems and repair another that won't work at all at the moment.

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Last edited by LPGC on Wed Nov 18, 2015 2:35 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 18, 2015 1:22 pm 
New member

Joined: Fri Aug 28, 2015 6:58 am
Posts: 8
Cheers for the replies guys. I will have a look the weekend as to what type it is.

Is there any Essex LPG pro's on this site?

Cheers

Adie


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 18, 2015 2:29 pm 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 3015
Location: Yorkshire
This won't apply in your case Adie but I've linked to this thread from another as it may help on the other thread.

LPGC wrote:
Just about to set off to a limo company to service a few BRC systems and repair another that won't work at all at the moment.
Been and sorted it, limo has recently had a new engine fitted, when reconnecting wiring the engine installer had attached the BRC system's + and - main power feeds respectively to either side of a high power fuse (that supplies power to the disco stuff in the rear end)... So the BRC system was getting + to it's - connection. This could have been disastrous and blown the BRC ECU completely, they were lucky it didn't, but it did melt the ECU chassis to earth connection. Nevertheless, after correcting a few other minor wiring issues the limo runs properly on LPG again.

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group