LPG Forum


All times are UTC



Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Poor hot starting
PostPosted: Thu May 04, 2017 5:59 pm 
Advanced Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 7885
Images: 0
Location: Peterborough
A mate has just bought a P38 GEMS Range Rover fitted with what appears to be a Prins VSi system (at least the switch has the Prins logo on it, there's 8 Keihin injectors under the bonnet and what looks like a Prins reducer but the label can't be seen on the controller). No problems with it running, pulls like a train and doesn't run out of puff up to the red line despite the engine having been fitted with a lumpier cam and Stage 2 heads, the only problem is hot starting. If he stops for a few minutes it is very reluctant to start so he has been switching back to petrol just before turning off. Then it will start first time and switch back over to gas almost immediately. My first thought was gas leaking into the manifold through an iffy diaphragm so we took the vacuum hose off (Tee'd into the vacuum line between the plenum and petrol pressure regulator) and put the pipe in a glass of water expecting to see bubbles but there were none. The injectors sound fine, beautifully quiet in fact so I can't see it being a leaking injector (especially as they are Keihins) but is there anywhere or anything else that would cause the problem?

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
Reply with quote  
 Post subject: Re: Poor hot starting
PostPosted: Thu May 04, 2017 6:48 pm 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 2987
Location: Yorkshire
Unusual for a Prins reducer to have a vacuum connector even fitted, wouldn't expect one on a P38, most Prins reducers where vacuum connection is fitted the vac connection on the reducer was fitted by the installer (reducer drilled and tapped to install the spud on the reducer).

When the engine is running on gas does it switch back immediately to petrol (no momentary pause in power)? Wondering if the installer wired it to disconnect the petrol pump, which (especially if there was also a slightly leaky petrol injector) could make for the symptoms described.

Unlikely to be a leaky Keihin but I have seen them... Do the pinch test on pipes to see if LPG pressure is maintained when the engine is off.

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
 Post subject: Re: Poor hot starting
PostPosted: Fri May 05, 2017 8:00 am 
Advanced Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 7885
Images: 0
Location: Peterborough
I assumed it was a vacuum pipe, I suppose it could even be the pressure release valve outlet that's been piped to the plenum but either way, no gas came out of it. As he's only just got the car he was waiting until I'd given it the once over before deciding whether to keep it or not (which he will be doing as it's very good) so I took it for a test drive. As we were approaching my house he said to hit the button to switch back to petrol and it switched immediately without even a hiccup so I doubt it's disconnecting the fuel pump. I'll do a pinch test when I next get to see it.

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
Reply with quote  
 Post subject: Re: Poor hot starting
PostPosted: Fri May 05, 2017 9:17 am 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 2987
Location: Yorkshire
The over pressure release is on the circumference of the unit, vacuum connection usually involves a normal type manifold spud screwed into an installer drilled / tapped hole in the front housing somewhere near where the allen key pressure adjuster pokes through.

Yeh doesn't seem fuel pump is disconnected.

They're a good reducer but Prins do seem to have more than fair share of leaky reducers - leaking gas through the unit's seals to atmosphere (as opposed to into the water circuit) or through the pressure release valve, often intermittently and/or depending on temperature of the unit. Can also fail in a way where vapour pressure slowly rises when gas isn't being used, can obviously only do that until the liquid gas between the reducer solenoid and reducer has been converted to vapour but can be enough to cause the release valve to open or injectors to leak. Potential for there to be an intermittent gas leak into manifold.

If there's a leak on the vapour side Prins will usually store an error for 'low pressure before switching', if reducer fails in the way where pressure rises after switch off there might be a stored error for 'idle pressure too high'.

Or for a slightly different tack.. could be a problem with the emulator boxes, they do much the same job as Pitagora's and are a common problem.

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
 Post subject: Re: Poor hot starting
PostPosted: Fri May 05, 2017 12:47 pm 
Advanced Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 7885
Images: 0
Location: Peterborough
The pipe came off the outside edge of the reducer, next to one of the coolant hose connections so from the sound of it, it is the pressure release outlet. We checked for bubbles with it running on gas so it could be a slight leak from the pressure relief valve when it is left standing when hot. Presumably the easy check would be to disconnect it from the vacuum line, plug the end of that and just let the pipe from the reducer dangle down to below the engine so any leakage falls to the floor.

Didn't check the fuel trims (it was bloody cold outside at the time) but from the way it runs on both petrol and gas, I wouldn't think there's a problem with the emulators.

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
Reply with quote  
 Post subject: Re: Poor hot starting
PostPosted: Fri May 05, 2017 4:39 pm 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 2987
Location: Yorkshire
Yeh seems like that's the PRV. That's the way to rule out PRV causing the problem... If PRV does vent after a period of time due to pressure build up it could point to a reducer problem other than PRV, would still want fixing but with PRV venting to floor it wouldn't cause the same problem.

What I was getting at with the emulator being like a Pitagora - If it sticks in the LPG mode (so functions like a Pitagora with 12v to the blue wire), the petrol injectors will be disconnected... but it seems unlikely this could be the problem since it switches back to petrol OK from driving on gas every time.

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: Brian_H, RodH and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group