LPG Forum


All times are UTC



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Thu Feb 02, 2017 1:03 pm 
New member

Joined: Sun Apr 21, 2013 8:52 pm
Posts: 2
Had a few issues with my system (europe gas) felt like it dropped 1/2 the Cylinders & absolutely no power. Also noticed the heating went on the car :shock: I checked the water & topped up, switched to petrol & all was good. Changed filter still the same on gas. Took it to local lpg guy
who said he had to change 3 injectors & remap. anyway all good & back on the gas.....FOR 3 WEEKS, same again. This time i bought another 3 magic injectors myself from lpg shop, & changed them over. Car idles ok, but no power under load. the heating also going cold again. Do i just need this remapped, or is there a bigger issue here :cry: . The car drives perfect on petrol & heating is as it should be.
Thanks in advance


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 02, 2017 9:49 pm 
Junior Member

Joined: Sun Oct 23, 2011 4:52 pm
Posts: 200
Location: West Sussex
Hi and welcome to the forum

If you switch pack to petrol do you get heat?

James


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 02, 2017 10:21 pm 
New member

Joined: Sun Apr 21, 2013 8:52 pm
Posts: 2
Yes perfect on Petrol, heat only goes if i switch to gas, gas idles ok, until i select gear then feels as if 1/2 the cylinders have gone , & within minutes, No heat.


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 02, 2017 10:35 pm 
Intermediate Member

Joined: Mon Jan 23, 2012 12:21 pm
Posts: 880
Location: Milton Keynes
Have a look at your vapouriser - something is wrong with it, could be allowing gas to escape into coolant, or its blocked internally or not getting a good flow through it for some reason.

What car is it fitted to? any idea how its connected to the heating system?

Would suggest you check the coolant level and run it for a day or so on petrol, recheck the level - if its not going down its probably either flow related or a faulty vapouriser (the seals inside can fail with age). If it does go down then its leaking somewhere, finding where and sorting it may be enough to resolve the other issues.

Might be worth checking that you have some coolant in the system as well?


Top
 Profile  
Reply with quote  
PostPosted: Fri Feb 03, 2017 12:02 am 
Installer

Joined: Fri Oct 21, 2005 7:56 pm
Posts: 2581
Location: North Wales
Could be the vapouriser leaking gas into the water system. Some of teh old magic jet reducers did suffer with that

_________________
http://www.classicswede.com/
http://www.classicswede.co.uk/LPG/cat17 ... 10800.aspx

LPG installer Anglesey North Wales

DIY LPG Kits

07824887160


Top
 Profile  
Reply with quote  
PostPosted: Fri Feb 03, 2017 1:41 pm 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 2961
Location: Yorkshire
Water issue solution provided by others above.

On the other (power on LPG) issue, when you fitted the new injectors did you fit the nozzles from the old injectors to the new injectors?

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group