LPG Forum


All times are UTC



Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Not running on LPG
PostPosted: Thu Aug 18, 2016 1:02 pm 
New member

Joined: Wed Sep 18, 2013 10:02 am
Posts: 32
The LPG on the merc appears to think it is empty when the guage is full, it reaches temperature and then when normally it would change over it just beeps and stays on petrol. The system if an OMVL Dream XXIN using the OMVL injectors, vaporiser and sensors. So far working on the assumption its just not conviced that gas is present I have guessed either one of the soloniods has failed or the pressure sensor on the back of one of the injector rails has died. So far testing has been limited to the soliniods, I removed the ECU and applied 12v to the tank soloniod, it clicked, I then applied 12 v to the one on the vaporiser.. no click, on removing the coil I found it has 2 cracks however when applying a multimeter I find it has a resistance of about 10 ohms (It's a 12v 11w coil) is this likely to be the cause, has the valve stuck?


Top
 Profile  
Reply with quote  
 Post subject: Re: Not running on LPG
PostPosted: Thu Aug 18, 2016 8:39 pm 
Intermediate Member

Joined: Mon Jan 23, 2012 12:21 pm
Posts: 925
Location: Milton Keynes
Is that 10 ohms with the coil disconnected? They usually run in parallel so if your testing with it still connected it may be running through the rear coil as well. 10 ohms sounds a little low, how does it compare to the rear one?

It does sound like the front valve could be gummed up - only way to tell is to take it apart and see really.


Top
 Profile  
Reply with quote  
 Post subject: Re: Not running on LPG
PostPosted: Fri Aug 19, 2016 12:15 am 
Member

Joined: Sun Aug 09, 2015 12:45 am
Posts: 322
A 12V 11W coil will take about 0.9A so the resistance should be about 13 to 15 ohms. However it's not an exact art with coils so 10 ohms isn't too far from the ball park although a little low. Best way to test it is remove the coil (should be a clip, nut or bolt holding it onto the solenoid post) and power it up with 12V either from the battery or a power supply, battery charger or similar.
Then get a steel bladed screwdriver and introduce it into the central hole where the coil would normally have the solenoid post. It should be pulled in if the coil is working.

Note that some solenoid coils have built in "flywheel diodes" to prevent back emf reaching the ECU when the power is removed. These appear to be connected back to front across the coil, this is normal but depending on your multimeter and which way you connected the leads from it, the flywheel diode could alter the measured resistance so try checking it again with your meter and check it reads the same both ways round. If one way it reads higher then the meter was probably measuring the combined resistance of the coil and flywheel diode and giving a lower reading, in which case take the higher reading as the coil resistance.

_________________
Cheers,
Dave


Somewhere in Suffolk with a Jeep, 2 Rovers and a V6 Volvo

Image


Top
 Profile  
Reply with quote  
 Post subject: Re: Not running on LPG
PostPosted: Thu Oct 06, 2016 11:04 am 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 3018
Location: Yorkshire
Old thread I know.. and one I missed but for future reference...

All good advice and very likely the reducer solenoid coil failed.

Coils may or may not be connected in parallel, if the Merc has more than 4 cylinders then the OMVL ECU will have 2 solenoid outputs, one output for the reducer (and can be connected in parallel with tank solenoid but usually isn't), a separate output one for the tank solenoid which isn't used if the solenoids are wired in parallel but usually is used. If the Merc is only a 3 or 4 cylinder model (not likely since the OP implied the system has 2 injector rails) then the ECU will only have one solenoid output so both solenoids would be wired in parallel. There is a tick box in software 'tank valve with dedicated wire' which should be set accordingly, especially if the LPG ECU is recent enough to feature on board diagnostics.

Many kinds of electrical issues can cause an ECU with OBD enabled not to attempt to switch to LPG but to report a fault by beeping the switch - OBD reports a problem with longer beeps than occurs when you've run out of fuel.

To get you running on gas before a new reducer solenoid coil arrives could - in case of 3 or 4 cylinder system could remove the plunger out of the reducer solenoid post, in case of more than 4 cylinders with OBD may also have to disable OBD error reporting. Removed reducer plunger isn't quite as safe as with reducer plunger fitted but is nothing like as unsafe as missing tank plunger.. and there are quite a few installs around that don't even have a reducer shut off solenoid. Should only be considered a temporary fix anyway.

An OMVL system won't have a pressure sensor on the injectors, sensors on injectors will be temperature sensors, very few systems feature pressure sensors on injectors, OMVL/AEB use a remote or inline pressure sensor.

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group