LPG Forum


All times are UTC



Post new topic Reply to topic  [ 109 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next
Author Message
PostPosted: Thu Feb 19, 2015 5:27 pm 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
Hi all,

I'm having problems with the fuel trims on my Jaguar S Type but 1st the history bit-

I fitted this 2nd hand Landi Renzo system (it's a landi ECU, injectors and vaporizer) to my Jag about 3 years and its been fine but did occasionally go lean but as I do did not understand the Landi's software it was left like this.
This car came to the end of it's life due to 240k miles and a 'hit and run' so I bought a newer S Type and over X-mas swap the lpg system over. It's again been running fine up to about a week ago then 1 morning it don't switch over to lpg until I was 10 miles from home (switch over temp set at 30c, lpg tank full, coolant full and car up to running temp and vap too hot to touch) and just after switching to gas the Restricted Performance came on for the whole journey. Then on the way home it switched over within 3 mins and again Restricted Performance.

Then I got home I plugged the laptop in and the lpg looks fine. Then 30 mins later the ecu has turned itself off (no lights) and gone into standby, so disconnected ecu plug and its now working. Gone to use the car 2 hours later and it's done the same again. I checked the battery/key on and earth feds which were all good. But now my fuel trims are all over the place, then idling on gas both banks are 15-22% and driving bank 1 is -4% to 22% and bank 2 is 0 to 25%. On petrol idling both banks about the same 0-7% and driving -3 to 14%.

Any ideas?
Thanks

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 19, 2015 8:48 pm 
Installer

Joined: Wed May 23, 2007 5:51 pm
Posts: 8096
Images: 0
Location: Wiltshire
57jam89 wrote:
Then 30 mins later the ecu has turned itself off (no lights) and gone into standby

That's your clue, from which all else probably follows.
Double check the system power and earth feeds, including fuseholder.
Pull the ECU plug and look for discoloured (overheated) pins.
If confident, open the ECU and reflow the solder joints for the connector.
Could be beyond economic repair though.

_________________
www.blazegas.com


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 19, 2015 9:03 pm 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
rossko wrote:
57jam89 wrote:
Then 30 mins later the ecu has turned itself off (no lights) and gone into standby

That's your clue, from which all else probably follows.
Double check the system power and earth feeds, including fuseholder.
Pull the ECU plug and look for discoloured (overheated) pins.
If confident, open the ECU and reflow the solder joints for the connector.
Could be beyond economic repair though.


Cheers, Yes I just double checked the power feds, fuseholder and earth. Also had a look at the ECU plug and it looks clean.
Also had problems today with the leds showing gas level, sometimes showing no leds and other times full tank (the tank is full).

Not to sure about opening the ecu up!

With the landi software not easy to use (have adjusted maps on Stag, BRC and Marrelli oscar) and injectors been very noisy, maybe it's time to change the front end.

Thanks.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 19, 2015 10:19 pm 
Installer

Joined: Wed Jul 27, 2011 7:21 pm
Posts: 3733
Location: Midlands
Sounds like you've had your fun out of that kit tbf. ;)


Top
 Profile  
Reply with quote  
PostPosted: Fri Feb 20, 2015 7:05 am 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
Just been using the car for a few hours and the ecu is now turning itself on and switching over to lpg ok.
But the fuel trims are changing from -25 to 25%.

Is this down to ecu fault, faulty/ worn injections or just not set up right?

Thanks.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Fri Feb 20, 2015 11:15 am 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 2989
Location: Yorkshire
As others have said there might be a problem with your ECU / earths / power feeds etc.

Also wouldn't be surprising if you had worn injectors etc.

But regards fuel trim issues - You did fit a petrol return on the newer S type...? Some of the early ones (first couple of years production) used a conventional mechanical fuel pressure regulator, after that they all have electronic control of the fuel pressure and need a fuel return to be fitted or you'll always get restricted performance mode due to fuel pressure readings going off the scale or not fluctuating. When restricted performance has come on, have you read the car's OBD codes?

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
PostPosted: Fri Feb 20, 2015 11:48 am 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
Yes I removed the fuel return from the old jag and fitted it on this one and the car's ecu is happy with the fuel pressure.
The car's fault codes are both banks going lean.

Thanks.

p.s do you still have the brc front end for sale?

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Fri Feb 20, 2015 5:17 pm 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 2989
Location: Yorkshire
57jam89 wrote:
do you still have the brc front end for sale?

I do... I might have dropped on when I sold the last one, then again the slow sell could be related to the time of year...

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
PostPosted: Fri Feb 20, 2015 5:45 pm 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
So do you think it's worth changing the injectors? Or with this ecu is it just not worth?
If yes then which injectors can I use, the software says

The injectors which can be installed are: - M (XJ 544.09, XJ 533.09 for LPG or XJM 544.09, XJM 533.09 for Methane) - K (18030023/L-R, 18030013/L-R) - L (LANDI RENZO)

Which I have no idea what the above is about!

Thanks.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Sat Feb 21, 2015 1:19 pm 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 2989
Location: Yorkshire
The injector list points to Matrix injectors, which are good units, and Landirenzo's own make injectors.. But you could fit other injectors of a similar electrical and performance spec, would suggest MagicJet.

If the system was working fine on your other Jag, would seem more likely you have introduced some kind of fault when you fitted the system to your latest Jag? Is this the same size engine, etc? I'm thinking maybe just calibration issues...

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
PostPosted: Sat Feb 21, 2015 8:09 pm 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
The old jag and new are both V6 3.0 autos. I did not do recalibration and I have used it from the 1st day back in the new year up to last week with no problems (about 2000 miles).

I'm thinking of swapping the injectors over to a set of Keihin which I have spare but just found they have different plugs.

Thanks.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Sun Feb 22, 2015 2:14 am 
Installer

Joined: Wed May 23, 2007 5:51 pm
Posts: 8096
Images: 0
Location: Wiltshire
Changing the injectors will not fix your ECU switching off.

No-one has suggested Keihin are a good equivalent to Matrix ; they aren't. They come in non-adjustable sizes to boot.

_________________
www.blazegas.com


Top
 Profile  
Reply with quote  
PostPosted: Mon Feb 23, 2015 6:56 am 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
Thanks, but the ecu is behaving itself at the moment.
I was just thinking of changing the injections to rule out worn injectors and help my fuel trims. Buit's a as the plugs are different and new plugs cost £60 its a too higher cost for a maybe.
The Keihin I have are the right colour for my engine.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Wed Mar 04, 2015 6:57 am 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
Well I have got a new app for my phone (torque unless) and have been watching fuel trims and then cruising at about 2000 rpm and I lift off pedal both bank's trim go to -25% and with foot back on power they shoot straight to 25% then back to around 15% then on gas. The petrol they stay within -10% and 10%.

Any ideas?
Thanks.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Wed Mar 04, 2015 9:01 am 
Installer

Joined: Wed May 23, 2007 5:51 pm
Posts: 8096
Images: 0
Location: Wiltshire
It's not delivering very well under load. That may be due to poor setup, poor choice of parts, wear and tear, fault(s), or a combination of all.
Is this the one with unusually low gas pressure?

_________________
www.blazegas.com


Top
 Profile  
Reply with quote  
PostPosted: Wed Mar 04, 2015 11:13 am 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
rossko wrote:
It's not delivering very well under load. That may be due to poor setup, poor choice of parts, wear and tear, fault(s), or a combination of all.
Is this the one with unusually low gas pressure?


The whole system is landi renzo and the vapouriser is preset at 0.95 bar and can't be adjusted. The landi injectors come in 3 sizes like keihins.

At the moment I don't have the cash for a new front kit so I'm thinking of replacing just the item what causing the trims problem.
I also have a spare set of keihins.

Thanks.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Tue Mar 10, 2015 10:36 am 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
So any advice on what to buy and where from?

Thanks.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
PostPosted: Tue Mar 10, 2015 11:56 am 
Installer

Joined: Wed May 23, 2007 5:51 pm
Posts: 8096
Images: 0
Location: Wiltshire
Don't know what's wrong with it, from the info offered.
For powering-itself-off, could be anything from a trivial wonky wire to a fried ECU. Will be an arse to find.
For fuelling issues, it could be derived from the same cause at an earlier stage, or as pointed out already a host of other setup, wear, or failure issues. That could be time consuming to track down, involve step by swaps, and still end up at fried ECU.

It's up to you at which point you draw the line. It might be worth getting someone else with experience to have a look for an hour.

_________________
www.blazegas.com


Top
 Profile  
Reply with quote  
PostPosted: Tue Mar 10, 2015 2:13 pm 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 2989
Location: Yorkshire
rossko wrote:
Don't know what's wrong with it, from the info offered.
For powering-itself-off, could be anything from a trivial wonky wire to a fried ECU. Will be an arse to find.
For fuelling issues, it could be derived from the same cause at an earlier stage, or as pointed out already a host of other setup, wear, or failure issues. That could be time consuming to track down, involve step by swaps, and still end up at fried ECU.

It's up to you at which point you draw the line. It might be worth getting someone else with experience to have a look for an hour.


I'll second that!

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
PostPosted: Wed Mar 11, 2015 6:55 am 
Member

Joined: Sun Jun 21, 2009 4:14 pm
Posts: 449
rossko wrote:
Don't know what's wrong with it, from the info offered.
For powering-itself-off, could be anything from a trivial wonky wire to a fried ECU. Will be an arse to find.
For fuelling issues, it could be derived from the same cause at an earlier stage, or as pointed out already a host of other setup, wear, or failure issues. That could be time consuming to track down, involve step by swaps, and still end up at fried ECU.

It's up to you at which point you draw the line. It might be worth getting someone else with experience to have a look for an hour.


Yes your all right, time to get a professional to look at it.

So rossko can you have a look at me for me?
I do have the software.

_________________
Nissan Skyline 350gt Lpg fitted by Lpgc.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 109 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group