LPG Forum


All times are UTC



Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Nov 17, 2016 1:11 pm 
Installer

Joined: Wed Sep 29, 2010 5:01 pm
Posts: 3018
Location: Yorkshire
Here's yet another RX300 I just re-calibrated (to sort an issue) and changed the vapour filter on.

The owner reported the engine warning light occasionally came on, particularly on cold days while at idle/low engine loads, only when running on LPG, fine on petrol. He has his own OBD2 scanner and already knew that the MIL light came on due to bank2 running rich.

I confirmed OBD2 reporting the MIL light on due to bank2 fuel trims at full negative. Freeze frame data showed this condition arose with coolant temp at 72c, IAT at 10c and at 700rpm, it also showed bank1 trims were also nearly fully negative at the same time and there was a pending code for bank1. Live data showed both banks fuel trims shifted towards zero on petrol but went very negative on LPG.

At this point I was happy to tell the owner that the problem would most likely be caused by incorrect LPG system calibration - because fuel trims on both banks were very similar this meant it was very much less likely that a single LPG injector (which would likely be on bank2) was at fault. I found calibration set with a multiplier of 135 (this is pretty much percent) and offset of -5 (0.05ms). The engine was rich across the load range, so I knew the multiplier should be reduced. Particularly rich at low pinj's, so I knew the negative offset should be increased. In the yard I adjusted mutiplier down to 120 and offset down to -15, which gave near neutral trims at idle, in gear and when loading the engine slightly against the torque convertor for a moment, so calibration was now already looking a lot better. Changed the vapour filter, the system had been serviced quite recently including changing of the reducer liquid filter so we didn't change the liquid filter on this occasion. Went for a drive with the laptop and scanner still connected up and I further adjusted the multiplier to 123 and offset to -20. I am confident this will prevent the MIL light coming on in future and will help with accurate fuelling.

In the pic the owner is pointing out the slightly leaking Prins lube distribution block. We didn't touch this because owner reckoned he didn't like the Prins lube and intends to return for an electronic Flashlube fitting at some point (I have one in stock but owner had other things to do). At least this Prins lube system injects lube into each of the 6 pipes between injectors and manifold, as opposed to injecting lube into the feed from reducer to injectors... in my experience injectors don't like lube fluid flowing through them. Obviously some sort of lube should be fitted on this Lexus.

Image

Owner got a bit fed up with other installers charging £100 just to lift the bonnet and not sorting problems so travelled the further 40 miles to me (relatively close compared to average distance those fed up of not getting issues sorted closer to home, or between me and their home, travel). Service, bit of fault finding, calibration and issues sorted by me £60 and job's a good 'un. Not a high percentage of installers even work on Prins systems, while those that do are generally 'Prins authorised dealers' and a lot of them charge what I'd consider well over the odds. Similarities to old fashioned closed shop attitudes including manufacturers and suppliers actively not wanting too many dealers within a certain area - pushes prices up that dealers think they can get away with perhaps because they figure they have a captive market, and doesn't do much to encourage dealers to keep on top of others in terms of skills etc (and I wouldn't rate skills of many in this bracket). It gets worse when manufacturers and suppliers think they can further prevent competition by e.g. making software require license codes so that only their less skilled installers are able to work on said systems. Other (none Prins) manufacturers/suppliers have the same attitudes, this will only ever be a negative for their customers.

The install isn't as neat as the ones I've converted - links to threads about those I've converted over the last few months here (these are besides the other few Lexus that I've fixed over the same couple of months that I didn't make threads about). Of course, those I've converted or repaired don't have MIL light issues etc ;-)
http://www.lpgforum.co.uk/viewtopic.php?f=27&t=14179
http://www.lpgforum.co.uk/viewtopic.php?f=27&t=14143

I suppose massive Keihin injectors wouldn't have made a neat install possible anyway. But I think the lube system piping and reservoir and the Prins ECU seem mounted in daft places (got to remove under bonnet trim to get to the lube reservoir, ECU to engine clearance is marginal and it's right above the engine). The owner reported the original Prins ECU failed after about 2 years and he was charged £350 for a second hand one to be fitted.. I hope it didn't just need a reset/re-activation - Prins ECU's sometimes seem to have failed but start working as normal following doing that.

Simon

_________________
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group