LPG Forum


All times are UTC



Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Wed May 09, 2012 10:42 am 
New member

Joined: Tue Sep 27, 2011 8:13 am
Posts: 92
Location: north england
Hi all.

Are there any EASTJET LPG engineers in the north-east/north-west/yorkshires/scotland areas of UK out there please?

The gas system installed.. (according to LPG cert) is..

tank:- tugra makina (66)
EasyJet regulator
equipment supplied by MicroMise AutoTech, Chelms, Essex. 2006.

As said in a previous post, having bought a Forester turbo, although its fine on petrol it jolts/judders/kangaroos sporadically on gas.

It stops after the turbo kicks in.

I've now changed the plugs to NGK and checked the air filter (brand new). HT Leads are standard (recommended) and are fine.

Next on the tick-list is..

- Service/check LPG system.
- replace fuel filter.
- MAF sensor - "the MAF sensor for a new genuine Subaru one"
- 02 sensor - “I did get the misfire cleared by changing the 02 sensor.”

does these sound logical?

Prob is, it was installed 300 miles away in Essex. Does therefore anybody know who can service my EastJet system please?

many many thanks...

ps. My 2 localist LPG centres didn't anything about the system and just refused to help. #Helpful

S


Top
 Profile  
Reply with quote  
PostPosted: Wed May 09, 2012 1:16 pm 
Intermediate Member

Joined: Wed Jan 28, 2009 9:31 pm
Posts: 851
Location: South Wales
From the pictures in your previous post, your regulator is not an easyjet item. you have easyjet injectors and it looks like an easyjet ECU but the regulator is not easyjet.

You can buy the lead online and i have given you all the info regarding the setup and where you can get the software and setup procedures.

Give West yorkshire autogas a call in leeds, speak to Alan, i know he used to do stuff with easyjet but whether he still does or not i am not sure.
Otherwise give me a call on 01600 714599


Top
 Profile  
Reply with quote  
PostPosted: Wed May 09, 2012 1:57 pm 
New member

Joined: Tue Sep 27, 2011 8:13 am
Posts: 92
Location: north england
OK, I'll try Tommo. I don't suppose you can tell me what filter I'll need? The local lads here didn't know.

http://carsinalbion.blogspot.co.uk

I've asked for an Alan down at WY Gas.

cheers

Steven


Top
 Profile  
Reply with quote  
PostPosted: Thu May 10, 2012 11:32 am 
New member

Joined: Tue Sep 27, 2011 8:13 am
Posts: 92
Location: north england
..just spoken to a couple of lpg engineers round here and they're suggesting a fuse or solenoid might to blame - could this be symptomatic with troubles I'm having? Would that be a fuse in the regular boxes somewhere? LPG indicator in cabin working fine.

This morning something worse happened. It was running as it has been for about 5 miles when I came to a junction. Switching over to petrol so it wouldn't stall. on exiting junction (at full throttle to 5k revs) when I hit 80 in 4th I switched back manually to gas to find... Nothing. And for the remainder of my commute everytime I switched over no fuel whatsoever. No revs. It just slowed then stalled. Switching back to petrol no problem. Huh>!>>!>!>> Lewft the car for 10 mins in layby as I spoke to LPG engineer, switched back on and.. It switched to LPG and ran as it had been. Yes I had most of a full tank of gas.

Anybody had this before..?

thanks in advance..

S


Top
 Profile  
Reply with quote  
PostPosted: Thu May 10, 2012 12:34 pm 
Intermediate Member

Joined: Wed Jan 28, 2009 9:31 pm
Posts: 851
Location: South Wales
If it was the fuse the system would not work at all and would stay broke till a new fuse was fitted.

You have a vapour filter in the line to the injectors, have you changed that?

also i mentioned about the liquid phase filter, and said for you to trace back from the vapouriser in the engine bay until you found the front lock off solenoid. If this was an original easyjet system the vapouriser and reducer are separate items with the solenoid and filter incorporated into the reducer. If it has had a different vap fitted that did not incorporate a filter solenoid, then you may not have any front end protection, (not good) this being the case then any bad stuff is getting straight into the vapouriser.

The system mechanically is the same as any other system so any LPG company can look at it and tell you what is happening.
You have a copy of the software, and a lead is available from the internet.

If you want to come all the way down to south wales i will quite happily look at it for you.


Top
 Profile  
Reply with quote  
PostPosted: Thu May 10, 2012 1:12 pm 
New member

Joined: Tue Sep 27, 2011 8:13 am
Posts: 92
Location: north england
Ok thanks again Ton.

the vapour filter - it has not been replaced - what type do I ask for?
Have you a web link to that type I need?

I'll convey all your details onto the local lpg engineer who I gave been talking it through with and hopefully with your excellent help we'll get somewhere..

..If not, I'm Alan at WestYorks Gas is in tomorrrow I'lll talk to him.. Otherwise, its a trip down to South Wales!

thanks again.

S


Top
 Profile  
Reply with quote  
PostPosted: Fri May 11, 2012 6:38 am 
Intermediate Member

Joined: Wed Jan 28, 2009 9:31 pm
Posts: 851
Location: South Wales
Any vapour filter will do, but here is a link to one on fleabay
http://www.ebay.co.uk/itm/LPG-Autogas-I ... 3a5c77bc1a


Top
 Profile  
Reply with quote  
PostPosted: Fri May 11, 2012 10:23 am 
New member

Joined: Tue Sep 27, 2011 8:13 am
Posts: 92
Location: north england
cheers Tom, I've ordered it now.

Other symptom I've found is that after 60mph on gas the 'Check Engine' light comes on. Switch it back to petrol, and it disappears. I'll ask the local Scoob forums for someone with a lead/software. But I'm a guessing fuel mix issue? running too lean due to...?

I've created myself a checklist (19 of..) ..those that I'm goin to have a go at include..

first of all, I checked if the vaporiser gets hot - it does. within 5 miles/8 mins.
Things I'll check this weekend are..

- Coolant level.
- where the lpg filter is.. (before/after the vaporiser?)
- check all the hoses & connections for cracks/looseness.
- a 'sticking valve' that feeds the vaporiser - I gues I'm looking for a valvd type-thing before that vapriser?
- 'air intake hose clamps are loose' - air intake to where?
- checking dist cap/coil/rotor arms - IF THEY ARE IN VIEW..

thanks again.,

S


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group